LibreOffice Writer/Immagini incorporate e collegate

Indice del libro

Quando si fa Inserisci → Immagine, sotto a sinistra si trova l'opzione Collega, come si può vedere nella Figura 20.

Questa opzione fa sì che l'immagine non venga inclusa nel file, soltanto collegata.

Per riuscire a vedere tuto ciò che segue potrebbe essere necessario dire a LibO di utilizzare i suoi propri dialoghi per caricare/salvare i fle invece dei dialoghi del sistema perché altrimenti alcune opzioni potrebbero non essere disponibili. Per questo andiamo su Strumenti → Opzioni → LibreOffice → Generale e selezioniamo l'opzione Usa finestre di dialogo di LibreOffice.

Figura 20: Collegare un'immagine

Quando si sceglie questa opzione il programma ci chiederà se veramente vogliamo fare quello che stiamo facendo, qual è il problema? Bene, se il file viene spostato in un altro sistema e ci dimentichiamo de portare anche l'immagine, finiremo con un file «rotto».

Writer immagazzina i collegamenti in forma relativa, perciò se si salva il file in Documenti/Lavoro e le immagini in Documenti/Lavoro/ Immagini sarà sufficiente, se si desidera spostare tutto il progetto in un altro computer, copiare in forma completa la cartella Lavoro.

Per far sì che le immagini collegate vengano incorporate nel documento è sufficiente andare in Modifica → Collegamenti, scegliere i collegamenti della lista e premere Interrompe collegamento.

Sfortunatamente non esiste un modo uguale e semplice per fare il contrario, cioè che un'immagine incorporata diventi collegata... esiste, però, un modo meno semplice del quale parleremo nella sezione E.3.2, All'interno di un file odt a pagina 289.

Utilizzando i menù nativi di LibO, come si può vedere nella Figura 20 si ha l'opzione di scegliere lo stile di cornice che si applicherà all'immagine indipendentemente che venga inclusa o collegata.

Più informazione sulle cornici nel capitolo C.7 a pagina