VirtualDubMod/Interfaccia

Sommario · Categoria

Come il suo capostipite, VirtualDubMod non pone particolare attenzione all'aspetto grafico della sua interfaccia utente. Ciò che può a prima vista apparire come un difetto, è stato invece estremamente caratterizzante per questo applicativo, che all'interno dell'affollato panorama del video editing si è sempre distinto e ha sempre conservato lo zoccolo duro di estimatori, perlomeno per certe specifiche fasi della produzione di un filmato digitale.

L'interfaccia di VirtualDubMod è divisa in 3 aree sensibili sovrapposte verticalmente:

Menu modifica

In un applicativo senza fronzoli la maggior parte delle funzionalità sono necessariamente accessibili dai menu di programma. VirtualDubMod modifica l'ubicazione di alcune funzioni assodate di VirtualDub.

File modifica

Il menu File, come nella maggior parte degli applicativi Windows, consente di aprire un file, salvarlo nei vari formati e dà accesso alle funzioni avanzate, analizzate nei moduli avanzati di questo tutorial. In aggiunta permette di salvare su disco le elaborazioni audio/video impostate nel programma per un dato filmato, in modo da poter procedere all'elaborazione vera e propria in seguito, magari durante le ore notturne. Queste impostazioni di processo sono letteralmente ciò per cui VirtualDubMod è stato lanciato dall'utente, quindi rappresentano il fine ultimo del programma, convertito in un file di script. Per questo motivo le scorciatoie da tastiera predefinite per caricare e salvare questi file (.vcf) sono gli importanti Ctrl+L e Ctrl+S. Per comprendere appieno questa scelta (comunque modificabile a piacere, come tutte le scorciatoie da tastiera di VirtualDubMod) sarà sufficiente paragonare i file di processo di VirtualDubMod ai file di processo dei vari applicativi per montaggio video, ad esempio i file .stu di Pinnacle Studio o .veg di Sony Vegas.

Edit modifica

Il menu Edit permette di effettuare selezioni e movimenti del cursore all'interno di un filmato. In particolare la selezione di una scena permette di focalizzare l'elaborazione ad una sola parte del filmato. Tutte le operazioni di editing (taglia, incolla, elimina, etc.) non intaccano il filmato origine, ma vengono interamente gestite in memoria fino al rendering finale. In questo senso l'unica differenza tra queste operazioni e l'uso dei filtri video riguarda la visualizzazione a video dell'anteprima: il risultato dell'applicazione dei filtri video appare nel pannello di output, mentre la selezione, lo spostamento, l'eliminazione o il mascheramento di una singola sequenza comportano un effetto su entrambi i pannelli. Conseguentemente in VirtualDubMod non vi è la possibilità di annullare una singola operazione di selezione. L'unica possibilità che l'applicativo offre in tal senso è rappresentata dall'ultima voce di questo menu: Revert all edits, che annulla tutte le operazioni effettuate sulla timeline, mantenendo valide tutte le altre elaborazioni impostate, come i filtri.

Particolarmente utili in questo menu sono le possibilità offerte dai vari metodi di navigazione nella timeline. L'applicativo permette infatti non solo di spostarsi a piacere all'N-esimo fotogramma o al tempo desiderato in ore:minuti:secondi; permette anche di saltare agevolmente al precedente o successivo frame/keyframe/drop frame, ovvero fotogramma/fotogramma chiave/fotogramma perso. Tra questi il più utile è lo spostamento di keyframe, che permette di spostarsi istantaneamente all'interno di filmati anche molto lunghi pur avendo un'anteprima in tempo reale del video della posizione del cursore. Il concetto di spostamento sui keyframe è simile al concetto di snap in alcuni applicativi.

Video modifica

Dal menu Video il programma permette di avere accesso alle impostazioni di elaborazione della parte video del filmato, nonché alla modifica della modalità operativa dell'elaborazione video. Da questo menu si accede anche alle impostazioni del codec scelto per la compressione video.

Streams modifica

Il menu Streams può rappresentare una sorpresa per gli utenti di VirtualDub versione standard. VirtualDubMod, infatti, sostituisce il vecchio menu Audio con un generico Streams che meglio identifica le possibilità ora offerte. Da questo menu è possibile accedere a tutti i flussi secondari (audio o testuali), nonché ai meta-tag assimilabili a questi (commenti o suddivisione in capitoli).

Tutte le funzioni dedicate al singolo flusso sono state spostate dal menu Audio di VirtualDub alla finestra Available streams che risponde alla voce Stream list di VirtualDubMod.

Options modifica

Il menu Options dà accesso alle varie opzioni di configurazione, per quanto riguarda sia l'interfaccia che le funzionalità vere e proprie del programma. La voce Preferences... in particolare viene analizzata in una voce apposita di questo tutorial.

Tools modifica

La voce Tools, assente nell'originario VirtualDub, permette di aprire un editor di script AviSynth, da impiegare magari come template di caricamento di un filmato, e addirittura un editor esadecimale con cui intervenire su un file con la precisione del singolo byte. Entrambi questi strumenti non intervengono sul filmato in quel momento aperto sulla timeline.

Help modifica

Il menu Help contiene più voci di quante sarebbe lecito attendersi, poiché VirtualDubMod ha scelto di mantenere intatte le voci di Help e About della versione di VirtualDub implementata. Conseguentemente vi è una doppia voce Help e addirittura una tripla voce About.

Regala un sorriso l'About di VirtualDubMod, con uno scroller in perfetto stile Guerre Stellari, come prevedibile in ambiente geek.


Finestre di input e output modifica

La maggior parte della finestra di VirtualDubMod è occupata da due pannelli ridimensionabili a piacere, contenenti la parte video del file di input e l'anteprima di quella del file di output.


Barra temporale modifica

Configurazione modifica