Blender CAM/Le schede di Blender CAM: differenze tra le versioni

+ categoria e rimpicciolisco immagini
mNessun oggetto della modifica
(+ categoria e rimpicciolisco immagini)
<br />
 
=== Le schede di Blender CAM ===
 
==== CAM Operations ====
[[File:Bc012.png|link=https://it.wikibooks.org/wiki/File:Bc012.png|alt=|nessuno|riquadrato]]
La scheda '''CAM Operations''' consente di inizializzare un nuovo progetto cam premendo il tasto '''+''' presente sulla desra della finestra. Il tasto meno cancella il progetto selezionato nella scheda. Il tasto tra il '''+''' e il '''–''' crea una copia del progetto selezionato nella scheda.
 
===== '''Operation presets''' =====
Nella parte inferiore è presente un menù a tendina '''Operation presets''' che se espanso consente di selezionare numerosi presets definiti dallo sviluppatore o salvati dall’utente. Per creare un nuovo preset premere il tasto '''+''' posto a fianco. Il tasto '''–''' cancella un preset.
 
===== '''Calculate path''' =====
Il tasto '''Calculate path''' consente di calcolare il percorso utensile: se la checkbox '''Auto export''' posta poco sotto è selezionata il file verrà scritto (sovrascritto se esiste già con quel nome) nel disco, in caso contrario il file verrà scritto su disco solo quando sarà premuto il tasto '''Export gcode'''.
 
===== '''Calculate path in background''' =====
consente di avviare il calcolo del percorso ma l’operazione non è bloccante (utile per calcoli impegnativi) consentendo all’utente di proseguire con la propria attività.
 
===== '''Simulate this operation''' =====
genera una skin attorno alla lavorazione effettuata.
 
===== '''Operation name e File name''' =====
consente di personalizzare il nome del progetto mentre '''File name''' di personalizzare il nome del file gcode esportato.
 
===== '''Source of data''' =====
Espandendo il menù a tendina '''Source of data''' si hanno tre opzioni: '''Object''', '''Group of objects''' e '''Image'''
 
 
Ogni operazione crea un nuovo oggetto nella finestra '''Outliner''', da qui è possibile selezionare, cancellare, rinominare, oscurare/rendere visibile, consentire o meno la selezione, inserire o meno l’oggetto nel rendering.
[[File:Bc013.png|link=https://it.wikibooks.org/wiki/File:Bc013.png|alt=|nessuno|riquadrato]]
 
==== CAM info e warnings ====
[[File:Bc015.png|link=https://it.wikibooks.org/wiki/File:Bc015.png|alt=|nessuno|riquadrato]]
 
==== CAM Operation setup ====
===== Angle of paths =====
In certe strategie (Parallel, Block etc.) consente di inclinare l'angolo di lavorazione
[[File:Bc050.png|nessuno|riquadratoborder|1100px]]
[[File:Bc051.png|nessuno|riquadratoborder|1100px]]
[[File:Bc052.png|nessuno|riquadratoborder|1100px]]
 
<br />
===== Inverse milling =====
La checkbox '''Inverse milling''' se selezionata inverte la lavorazione con una specchiatura negli assi '''X''' e '''Y.'''
[[File:Bc016.png|link=https://it.wikibooks.org/wiki/File:Bc016.pngnessuno|alt=|nessunothumb|riquadrato1100px|Senza Inverse milling]]
 
 
 
 
===== Skin =====
====== heght of bridges ======
l'altezzaezza dell'oggetto bridge
 
 
e un campo '''Bridges Group''' che consente di selezionare un gruppo di '''Bridges''' che può anche essere generato premendo il tasto '''Autogenerare bridges'''.
 
Esempio d'uso: inserire nella scena di Blender una curva con '''Shift+A>Curve>Circle''', scegliere la strategia '''Prifile(Cutout)''', nel campo '''Cut''' impostare '''On line''' (a altro) e premere '''Calculate path''' da '''CAM operations'''.
[[File:Bc054.png|thumb|nessuno|riquadrato1100px]]
abilitare ora la checkbox '''Use bridges''' e premere il tasto '''Autogenerate bridges''', nell'albero '''Outliner''' appariranno nuovi elementi nominati '''bridge''', '''bridge_oo1''', '''bridge002''' ecc.. Selezioniamo nel campo '''Bridge Groups''' il gruppo appena creato '''bridges_Operation_1''' e facciamo ricalcolare il percorso con '''Calculate path'''. Si noterà che in corrispondenza degli oggetti bridge il percorso obbligherà l'utensile ad alzarsi del valore impostato in '''height of bridges'''
[[File:Bc055.png|thumb|nessuno|riquadrato1100px]]
 
Gli oggetti bridge una volta selezionati nella scena di Blender si possono spostare, scalare e cancellare a piacimento.
===== Use array =====
 
La funzione '''Use array''' consente di generare dei cloni del percorso a quote preimpostate; supponendo di dover lavorare dei pezzi identici bloccati nel piano della fresatrice a passi prestabiliti
[[File:Bc018.png|link=https://it.wikibooks.org/wiki/File:Bc018.pngthumb|alt=1100px|nessuno|riquadrato|funzione Use array disabilitata]]
[[File:Bc019.png|link=https://it.wikibooks.org/wiki/File:Bc019.pngthumb|alt=1100px|nessuno|riquadrato|funzione Use array abilitata]]
<br />
 
==== CAM Optimization ====
<br />
 
==== CAM Operation area ====
<br />
 
===== '''Use Layers''' =====
Nella scheda '''CAM Operation area''' è possibile abilitare la checkbox '''Use Layers''' che consente di eseguire una serie di passate (sgrossatura) fino ad arrivare alla superficie del pezzo con un valore impostabile dallo slider '''Step down'''
[[File:Bc020.png|link=https://it.wikibooks.org/wiki/File:Bc020.pngthumb|alt=1100px|nessuno|riquadrato|funzione Use layers disabilitata]]
[[File:Bc021.png|link=https://it.wikibooks.org/wiki/File:Bc021.pngthumb|alt=1100px|nessuno|riquadrato|funzione Use layers abilitata e Step down impostato ad 1mm]]
 
<br />
 
===== Use limit curve =====
'''Use limit curve''' consente di limitare l’area di lavoro ad una curva generata dall’utente a piacimento. Per aggiungere una curva in Blender posizionare il cursore del mouse nello spazio 3D, premere '''Shift+A''' e scegliere '''Curve>Bezier''' o '''Circle''', scalare eventualmente la curva e posizionarla secondo esigenza. La curva Bezier è possibile allungarla premendo '''Tab''' per entrare in '''Edit Mode''', selezionare l’ultimo nodo ed estruderlo premendo il tasto '''E.''' Se si dovesse aver necessità di chiudere la curva premere '''Alt+C''' quindi uscire dalla modalità '''Edit Mode''' con '''Tab'''.
[[File:Bc022.png|link=https://it.wikibooks.org/wiki/File:Bc022.pngthumb|alt=1100px|nessuno|riquadrato|Use limit curve disabilitato]]
[[File:Bc023.png|link=https://it.wikibooks.org/wiki/File:Bc023.pngthumb|alt=1100px|nessuno|riquadrato|Use limit curve abilitato]]
Selezionare nel campo '''Limit curve''' la curva creata in precedenza.
<br />
 
===== Cutter stay in ambient limit =====
'''Cutter stay in ambient limit''' vincola l’utensile a rimanere entro i limiti del blocco impostato nella scheda '''CAM Material size and position'''
 
==== '''Bas relief''' ====
 
 
'''Bas relief''' consente di generare un'immagine con estensione '''.exr''' con la quale è possibile deformare un plane in Blender ottenendo così un bassorilievo lavorabile a CAM.
La procedura per ottenere tale immagine è la seguente:
 
1-# Importare in Blender l'oggetto solido di cui si vuole ricreare il bassorilievo (io aggiungo nella scena '''Monkey''' premendo '''Shift+A>Mesh>Monkey''')
2-# Aggiungere un '''Plane''' dietro l'oggetto [[File:Bc040.png|thumb|1100px|nessuno|]]
 
3-# Scegliere il motore di rendering '''Cycles Render'''
2- Aggiungere un '''Plane''' dietro l'oggetto
4-# Impostare una vista con la telecamera a piacimento (è possibile farlo anche con lo shortcut '''Ctrl+Alt+0''') [[File:Bc041.png|thumb|1100px|nessuno]]
[[File:Bc040.png|nessuno|riquadrato]]
5-# Selezionare '''Camera''' e nella '''Properties>Data>Display''' abilitare la checkbox '''Limits'''
 
6-# Selezionare '''Camera''' e nella '''Properties>Data>Lens''' impostare il valore di '''end''' in modo tale che la linea arancione della fotocamera copra solo la profondità della scena subito dopo il '''Plane''' [[File:Bc042.png|thumb|1100px|nessuno]]
3- Scegliere il motore di rendering '''Cycles Render'''
7-# Nella '''Properies>Render>Output>File Format''' scegliere '''OpenEXR''', '''BW''', abilitare la checkbox '''Z Buffer'''
 
8-# Nella '''Properies>Render>Dimension'''s impostare dei valori abbastanza alti [[File:Bc043.png|thumb|1100px|nessuno]]
4- Impostare una vista con la telecamera a piacimento (è possibile farlo anche con lo shortcut '''Ctrl+Alt+0''')
8-# Aprire il '''Node Editor''' e selezionare '''Compositing''' e '''Use Nodes'''
[[File:Bc041.png|nessuno|riquadrato]]
9-# Aggiungere il nodo '''Normalize''' con '''Shift+A''' fino ad ottenere quanto visibile nell'esempio [[File:Bc046.png|thumb|1100px|nessuno]]
 
10-# Da '''Properies>Render''' premere '''Render''' ('''Actiive Scene''') oppure il tasto '''F12''', alla fine del processo '''Esc''' per uscire
5- Selezionare '''Camera''' e nella '''Properties>Data>Display''' abilitare la checkbox '''Limits'''
11-# Cambiare il motore di rendering in '''Blender CAM''' e nella scheda '''Bas Relief''' nel campo '''Image source''' selezionare '''Viewer Node''', nel campo '''Image target''' inserire un nome a piacere ('''BasRelief''') quindi premere '''Calculate Relief''' [[File:Bc047.png|thumb|1100px|nessuno|]]
 
12-# Nella propria home directory (Gnu/Linux) apparirà l'immagine '''BasRelief.exr'''
6- Selezionare '''Camera''' e nella '''Properties>Data>Lens''' impostare il valore di '''end''' in modo tale che la linea arancione della fotocamera copra solo la profondità della scena subito dopo il '''Plane'''
[[File:Bc042.png|nessuno|riquadrato]]
 
7- Nella '''Properies>Render>Output>File Format''' scegliere '''OpenEXR''', '''BW''', abilitare la checkbox '''Z Buffer'''
 
8- Nella '''Properies>Render>Dimension'''s impostare dei valori abbastanza alti
[[File:Bc043.png|nessuno|riquadrato]]
 
8- Aprire il '''Node Editor''' e selezionare '''Compositing''' e '''Use Nodes'''
 
9- Aggiungere il nodo '''Normalize''' con '''Shift+A''' fino ad ottenere quanto visibile nell'esempio
[[File:Bc046.png|nessuno|riquadrato]]
 
10- Da '''Properies>Render''' premere '''Render''' ('''Actiive Scene''') oppure il tasto '''F12''', alla fine del processo '''Esc''' per uscire
 
11- Cambiare il motore di rendering in '''Blender CAM''' e nella scheda '''Bas Relief''' nel campo '''Image source''' selezionare '''Viewer Node''', nel campo '''Image target''' inserire un nome a piacere ('''BasRelief''') quindi premere '''Calculate Relief'''
[[File:Bc047.png|nessuno|riquadrato]]
 
12- Nella propria home directory (Gnu/Linux) apparirà l'immagine '''BasRelief.exr'''
 
 
 
Per generare un bassorilievo da un'immagine '''.exr''' dobbiamo aggiungere un '''Plane''' alla scena ('''Shift+A>Mesh>Plane)''', premere '''Tab''' per entrare in '''Edit Mode''' e dalla '''Tool Shelf''' (tasto '''T''') premere più vole '''Subdivide'''.
 
Ora da '''Properies>Texture''' premiamo '''New''' ('''Add new Texture'''), dalla scheda '''Image''' selezioniamo '''Open''' e clicchiamo su '''BasRelief.exr''' appena creata.
[[File:Bc044.png|nessunothumb|riquadrato1100px|nessuno]]
 
Con il Plane selezionato premiamo '''Properies>Modifiers>Add Modifier>Displace''', nel campo '''Texture''' ('''Browse Texture to be linked''') scegliamo la '''Texture'''. Abbassiamo ad un valore tra '''0.1''' e '''0.2''' lo slider '''Strength''' fino ad ottenere il risultato desiderato.
[[File:Bc045.png|nessunothumb|riquadrato1100px|nessuno]]
 
<br />
[[Categoria:Blender CAM|Schede di Blender CAM]]